We are experiencing issues with one of our partners for virtual card creation
Incident Report for Extend
Resolved
This incident has been resolved.
Posted Apr 01, 2022 - 06:51 MST
Update
We are experiencing issues with one of our partners for virtual card creation
Posted Apr 01, 2022 - 05:55 MST
Identified
The issue has been identified and we are reaching out for a better timeline
Posted Apr 01, 2022 - 05:54 MST
Update
We are continuing to investigate this issue.
Posted Apr 01, 2022 - 05:54 MST
Investigating
We are experiencing issues with one of our partners for virtual card creation
Posted Apr 01, 2022 - 05:53 MST