9/1 incident
Incident Report for Extend
Resolved
This incident has been resolved.
Posted Sep 01, 2022 - 16:04 MST
Investigating
Please be aware that some Extend customers may be experiencing issues creating virtual cards. We are researching the issue and treating this with the utmost urgency. We will notify when this is resolved.
Posted Sep 01, 2022 - 12:17 MST