Missing/delayed transactions
Incident Report for Extend
Resolved
This incident has been resolved.
Posted Aug 09, 2022 - 09:52 MST
Investigating
We are experiencing issues with one of our partners for virtual card transactions.
Posted Aug 06, 2022 - 13:15 MST